
Page 1

A Brief Introduction to Digital Photography
Presented by Tom and Mary O'Haver

emails: toh@umd.edu     ohaverma@verizon.net

This document is online at http://tinyurl.com/amreswe 

 igital photography has now almost completely replaced film photography for most 
applications, except for some serious professionals. Digital is cheaper in the long run, can 
take both still pictures and videos, and is faster and more flexible with respect to 
automating the camera's settings when taking pictures, correcting photographic flaws after 
the picture is taken, and displaying and sharing the resulting photos with others. The 
simple fact is that the average person can usually get better results with digital than with 
film cameras. (For more on this, go to http://tinyurl.com/3ppuz). Moreover, digital 
photos are easier to organize, annotate, share, and store than film. Many people are busily 

scanning and digitizing their family's collections of old photos, negatives, and slides for that reason. 
   In this course we will take a brief look at digital cameras and some of the computer software that 
allows you to take, save, and use photographs as never before. 

A. Features of Digital Cameras
1. Megapixels (MP). The first thing mentioned in digital camera ads is usually the camera's  

resolution in megapixels. Pixels are the tiny dots that digital pictures are made of; a megapixel equals 
1 million pixels. The more megapixels, the more dots in the image and the greater the potential for 
capturing image detail. How many pixels you really need depends on what size prints you plan to 
make. The rule of thumb is that you need 3 megapixels to make a decent 8 x10 print (the largest size 
that most computer printers can make). For 4x6 or 5x7 prints, email, and Web pages, 2 megapixels is 
more than enough. More megapixels won't necessarily make small pictures look any better! Even a 
high-definition TV screen has only 2 megapixels. Any camera now being sold has at least 3 mega- 
pixels and is adequate for basic snapshots. Higher resolution (5 megapixels and over) can give higher 
quality large prints (8x10 and 11x14), but the main advantage of high-resolution cameras is that they 
usually have better optics than cheaper cameras, plus you can blow up a small portion of a high-
resolution picture and still have enough pixels left. But there are some disadvantages of high 
resolution: you can't take as many pictures on one memory card, the pictures take up more space on 
your hard drive when you import them into your computer, and the larger images are slower to work 
with. (For these reasons, you can set your camera to a smaller image size if you're not planning to 
make huge blow-ups; refer to your camera's manual for details). Megapixels is not the only thing that  
determines photo quality! For a striking example of this, go to http://tinyurl.com/bxoxvhw 

2. Zoom range. Most digital cameras come with a zoom feature that lets you change the image magni- 
fication, so you can “zoom in” on distant objects, like using binoculars. For example a “3X” zoom 
lets you increase the magnification 3 times. Zoom is especially good for outdoor, sports, and nature 
photography. “Optical zoom” is the only real zoom. Sometimes cameras will also specify a “digital 
zoom” range, but that is unimportant because it is simply equivalent to “cropping” the picture, which 
you can always do after-the-fact using photo editing software. (“Total zoom” is just the optical zoom 
times digital zoom). “Superzoom” cameras have an extended optical zoom range of x10 to x24 or 
more; on such cameras, built-in image stabilization is now standard, to help compensate for camera 
movement when the camera is hand held. See http://tinyurl.com/ajscz6m for some examples.

3. Automatic or manual exposure control. All digital cameras have automatic exposure control; that 
is, they change their lens opening and shutter speed automatically in varying light conditions. A good 
feature on some cameras is the “spot metering” mode, which automatically adjusts the exposure for 
the center of the frame only; this is good for “backlit” subjects (dark subjects in front of a brightly-lit 
background) that would otherwise be underexposed. Some cameras detect peoples' faces and auto- 
matically adjust the exposure and focus for those faces, assuming that people are the main subject.
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4. Automatic or manual focus control. Some very simple cameras are preset to a fixed focus on a 
specified range, perhaps 6 feet to infinity. But most digital cameras have “autofocus”, which usually 
uses a spot in the center of the scene to automatically focus the camera's lens. This works fine when 
there is something in the exact center of the scene that you want to be sharply focused. Fancier 
cameras also have manual focus, which allows you to override the autofocus when it does not do 
what you want. Autofocus typically does not work well in low-light situations. (Tip: One important 
factor is the speed of the autofocus; if it's too slow it will create a slight delay between pressing the 
shutter button and the instant when the picture is actually taken. Try before you buy.) 

5. Removable storage. Different cameras use different systems for storing images. The most common 
system uses reusable "memory cards", small removable cards that store your pictures electronically. 
Memory cards come in several different types (e.g. SD, XD, Memory Stick, etc), sizes, and speeds. 
You must use the type that is compatible with your camera. Once your card is filled up with pictures, 
you have to replace it with an empty one or copy your images to your main computer's hard drive 
before you can erase and re-use that storage card. The larger the capacity of the card, the more 
pictures it will hold. For example, an 8 Gbyte card can hold a thousand photographs or more, 
depending on the resolution setting of your camera. These cards are getting cheaper all the time. 
(High-speed cards are preferable, especially if shooting videos, but are more expensive).

6. Essential accessories. Many digital cameras are sold stripped-down, without accessories that you 
might eventually need. For example, extra batteries are essential. Some cameras are sold only with 
non-rechargeable batteries that drain very rapidly, so you may want to buy rechargeable ones and a 
battery charger. Buy at least two sets of batteries, so one can be charging while you are using the 
other, and an extra charger. Also, digital cameras are usually sold with only a single memory card, 
often of small capacity. Buy some extra ones, possibly with larger capacity, to carry with you.

7. Size and weight. Digital cameras can be remarkably small and light (4 - 8 oz). The smallest ones are 
usually simple models without much zoom range; nevertheless, they often take great pictures. 
“Compact superzoom” cameras combine small size with great zoom range. But if you are an 
experienced shutterbug who is accustomed to 35 mm film cameras, you may want one of the larger 
models with a longer zoom lens, because they feel and act more like a 35 mm camera. The ultimate 
professional model is a big, heavy digital SLR (Single Lens Reflex) with interchangeable lenses, 
usually with a resolution of 18 MP or greater, which cost $600 or more; that's overkill for most of us. 
As with any camera, the quality of the optics is paramount. Bigger is not necessarily better.

 8. Flash. Most cameras have a built-in on-camera flash. These are convenient, but an on-camera flash 
does not give very good-quality flash pictures. If you take a lot of indoor pictures with flash, look for 
a camera with a "hot shoe", which is a little mounting bracket on the top of the camera that allows 
you to attached a "bounce flash" unit, separately available for about $100. This is the type of flash 
that professional photographers use; it allows the flash head to be tilted up to bounce off the ceiling 
or a wall, giving a much softer and more flattering look to the pictures - and no “redeye”! See 
http://tinyurl.com/a33yeso for a dramatic photo comparison.

9. Ease of use. This is an important but ultimately subjective factor. Point-and-shoot cameras are the 
simplest to operate and are relatively inexpensive; they usually provide 5-12 mega-pixel resolution, 
fully automatic exposure and focus, and most provide modest optical zoom (x3 - x12). More 
advanced cameras and professional cameras are much more flexible, but they are heavier and have 
many more buttons and controls, which may require that you read the manual to learn how to use 
them - and also increases the chance that one of the controls may accidentally be set incorrectly (a 
common nuisance). If you are in doubt, start out with a point-and-shoot camera at first, and then if 
you want or need more, migrate to a more advanced camera when you know what features and 
capabilities are important to you. Always, always, save your receipt; if a camera is too much to figure 
out, return it and try another model. 

10. Speed of operation. You may notice a slight delay between pressing the shutter button and actually 
capturing the image; it occurs while the camera clears the image sensor, sets white balance to correct 
for color, sets the exposure, focuses the image, and finally fires the flash (if it's needed) and takes the 
picture. Another delay occurs between pictures, when the captured image is stored on your 
removable storage card and the flash is recharged; this delay can range from a fraction of a second to 
as much as 1-2 seconds. These delays can be troublesome when you are taking fast-action pictures 
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(sports, etc). Newer models of cameras have reduced these delays considerably, but it's still a good 
idea to try out a camera before you buy to see if these delays are bothersome. 
Here's a trick for fast-action photography that will work on most cameras: when you have your 
subject in the viewfinder, press the shutter button half-way down (which locks in the exposure and 
focus), then wait for the right moment and press the button all the way down to snap the picture 
instantly. Some cameras also have a "burst mode" that can take a quick sequence of several shots 
when you hold down the shutter button, maybe 5 shots in one second - great for capturing fast action. 

11. GPS locator. Some new cameras (smartphones; Lumix ZS10) have a "GPS chip" that records the 
exact place each picture was taken, often to an accuracy of a few yards. This is a great feature for 
travel photography. Picasa's Places button will pinpoint the exact location on a world map. Note: 
This feature does not work well inside buildings, so first snap a picture outside to mark the location.

12. Cell phones. Most recent cell phones and tablets can take good-quality still photos and videos. 
Smartphones like the iPhone can wirelessly import to your computer, email, upload to the Web, 
Twitter, or Facebook, or print photos right from the phone with just a couple of clicks. Some have 
built-in flash, face recognition, panorama, and GPS, but they do not have built-in optical zoom. 

13. Resources and recommendations. For a very nice illustrated introduction to choosing a digital 
camera, go to http://www.shortcourses.com. Good places to compare features and prices of the best 
(and worst) digital cameras are http://www.digitalcamera-hq.com and http://www.imaging-
resource.com. Consumer Reports magazine regularly tests and reviews cameras and printers and 
recommends specific models. Ask a friend; try their cameras. Maybe you'll find something you like.

B. Storing and Using Digital photographs
You'll probably want to transfer pictures from the camera to a computer or laptop for long-term storage 
and easy access. Use any software for that purpose: it can be the software that came with your 
computer or with your camera (but it does not have to be), or use Windows Photo Gallery, or the 
Scanner and Camera Wizard, or any other photo program. Use whatever works for you. 

There are two ways to connect the camera to the computer: (a) connect the camera directly to an 
available USB port with the cable supplied with the camera, or (b) remove the memory card from the 
camera and insert it into a card reader slot (on the computer, on the printer, or in an add-on card reader). 
The latter is more reliable. If a pop-up menu of choices appears when the camera or camera card is 
connected, use any one of these three techniques: (a) click “Copy pictures to a folder on my computer” 
and follow the on-screen instructions, or (b) click “Open folder to View Files”, select the pictures you 
want to transfer, click “Copy the selected items”, select My Documents > My Pictures in the pop-up 
box, and click Copy, or (c) click “Copy pictures to your computer and view them using Picasa”. 

Picasa is a very popular photo organizer from Google. It's free, available for Windows and Macintosh, 
easy to use, and it automates a lot of things that you might find useful. You probably don't need Picasa 
if you are already successfully using another program, but if you are not comfortable with the standard 
Windows operations and programs that came with your computer, give Picasa a try. 

Installing Picasa
 1. Open your web browser, go to http://picasa.com, and click Download Picasa.
2. Click Run, I Agree, Install, then Finish. You can then run Picasa by double-clicking the Picasa 

icon on the desktop or by clicking Start > Programs > Picasa 3 > Picasa 3.
3. The first time you run Picasa (and only the first time), it asks you where to look for pictures. Select 

“Documents, Pictures, and Desktop” rather than “Entire computer”. It then searches those locations 
looking for digital photographs, creating an index of all the photos there. It's important to under- 
stand that Picasa does not actually move or duplicate your photos. It leaves them where they were 
and simply makes a index of them, like a card catalog in a library. The indexing may take several 
minutes to complete, depending on how many photos you already have on your computer. You can 
begin exploring Picasa even as it continues to index your photos. (While it's doing that, I suggest 
that you pull down the Tools menu, select Options..., click on the Name Tags tab (the last one on 
the right), un-check the two check boxes, and click OK. Then select View > Thumbnail Caption > 
Caption. That will make Picasa a bit easier to use).

http://support.apple.com/kb/HT4486
http://picasa.com/
http://www.imaging-resource.com/
http://www.imaging-resource.com/
http://www.digitalcamera-hq.com/
http://www.digitalcamera-hq.com/articles/the-best-and-worst-digital-camera-trends-of-2012
http://www.shortcourses.com/
http://terpconnect.umd.edu/~toh/adulted/Fullscreen%20capture%201142013%20121900%20PM.bmp-001.jpg
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Using Picasa: The main screen (Library)
The main screen of Picasa shows the master index of photos, called the Library. The left-hand panel 
shows all the folders containing photos, and the right-hand panel shows small images (called “thumb-
nails”) of all the photos. The thumbnails are listed by date, with the most recent at the top. You can 
scroll through the folder list or through the library of thumbnails by using the mouse wheel or the scroll  
bars. Click once on a folder listed in the left-hand panel to jump directly to those pictures. The slider at 
bottom right changes the size of the thumbnails. It's very important to understand that, although the 
pictures may look like they are “in Picasa”, they are actually on your hard disk where they always were; 
Picasa just creates an index of them, like a library card catalog. Click once on a thumbnail to select it: 
The blue bar just below the thumbnails shows the date and time when that photo was taken, the pixel 
dimensions (height and width), and the file size (disk space used by that photo). Note: Make sure your 
camera 's clock/calendar is set correctly so that these dates and times will be correct (if not, look up 
how to set it). To return to the Library from other Picasa screens, press the Esc key (upper left).

Viewing pictures in a full-screen slide show 
To view pictures full-screen, click on the folder or album of photos that you want to see, click the Play 

 button, then either let the slide show run by itself or move the mouse and use the buttons at the 
bottom of the picture to view the next or previous picture in that folder or album. Rotate sideways 
pictures by clicking on the curved arrow buttons at the bottom. Zoom in to pictures by holding the 
mouse button down, then dragging the photo. To return to the library view, press the Esc key (upper 
left corner of keyboard) or click the Exit button in the lower left of the screen. 

Importing new photos from digital cameras and card readers using Picasa.
1. Connect the camera or card reader to your computer. If a pop-up window appears, close it. 
2. Click the Import button  in the upper left of the Picasa window.
3. Wait for the thumbnails to load. (Pictures with a red X have already been imported via Picasa and 

will be skipped). If nothing happens, click Import From and select the desired device. 
4. Click My Pictures in the Import to menu and type a title for those photos into Folder title box. 
5. Use the After Copying menu to choose whether you want the card erased automatically or not, 

then click the Import All button. Note: It's safer to choose “Leave card alone”, and then to erase 
the memory card later, just in case something goes wrong with the import.

Picasa puts all the imported photos initially into one folder. To divide one folder of photos into two 
folders, right-click on the thumbnail where the second group begins, select Split Folder Here, type the 
name for the second group, and click OK. To move pictures from one folder to another, scroll to the 
desired thumbnails, hold down the Ctrl key and click each thumbnail once, then scroll the folder list 
(without clicking) to the destination folder, and drag any one thumbnail to the left and drop it into that 
folder. To move a group of pictures into a new folder, hold down the Ctrl key and click each thumb-
nail once, click File > Move to New Folder...., type a name for the new folder, and click OK. 
Warning: Don't Import photos that are already on your hard drive. That just creates duplicates.

Organizing and labeling folders  
  The first thing you should do after importing new photos into your computer is to organize them by 
subject or event and label them appropriately to find them more easily later. You can change the folder 
name or add information at any time: just double-click on the folder name, then edit the name, 
description, date, or place taken, and click OK. If you find that photos in one folder were taken at more 
than one place and time, it's best to divide them up, as described in the previous paragraph. 
To delete a picture from the disc, select it, then press the Delete key. To delete a folder, select all the 
pictures in it (Ctrl-A) and press the Delete key. It's important to understand that if you use Picasa to 
delete a picture, it's actually deleted from the hard disk (and moved to the computer's recycle bin). 
Note: Do not right-click and select Delete folder; that's too dangerous. Delete all the pictures instead.
Sorting: To sort the folder list, click  at the top left. To sort the pictures within a folder, right-click on 

that folder and select Sort Folder by > Name, Date or Size. 
Note: If Picasa does not immediately recognize a newly added photo, select File > Add File to Picasa, 

navigate to the folder containing the photo, click on the photo, and click Open. 
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Adding Captions and Text . 
 To add a caption below a photo, double-click on the thumbnail, type a caption in the space below the 
photo where it says “Make a caption!,” and press the Enter key. Captions are displayed in Picasa slide 
shows and in movies. (Note: If the captions don't appear below the thumbnails, select View > Thumb-
nail Caption > Caption). To type directly onto the photo, click “Text” in the left panel, type anywhere 
on the photo (or click Copy Caption button), adjust the font, size, etc, and click Apply.

Searching for photos by keyword, folder name or caption 
  To search for photos by keyword, type a keyword next to the magnifying glass icon at the upper right 
of the screen. All the matching photos will be displayed instantly. Picasa searches for matches in the 
folder names, descriptions, place taken, file names, and in any added captions. This is why you should 
label your folders and/or caption your photos appropriately (see previous sections). Click the green 
Back to View All button at the top to return to the full library display.

Enhancing pictures and correcting photographic flaws
1. Open the picture for editing by double-clicking on its thumbnail. Click the  tab at the top of the 

left-hand panel.
2. Click the I'm Feeling Lucky button  to auto-adjust the brightness range. If you don't like the 

result, click the Undo... button to remove the effect. 
3. If the dark portions of the photo seem too dark, drag the Fill Light slider  in the left-hand 

panel to brighten the dark portions. 
4. To crop the picture, click the Crop button  in the left-hand panel, click, hold, and drag over the 

picture to select the area. (The pop-up menu lets you select several standard formats for prints, 
TV, photo frames, etc.)  Click the Apply button to accept, or Cancel to exit the crop mode.

5. To fix red-eye, click the Red-Eye button  in the left-hand panel, then click the Apply button to 
accept the correction OR click Reset to remove the correction. You can also manually click, hold 
and drag the mouse over each eye. Click Cancel to exit the Red-eye mode. 

6. To retouch a photo with a blemish, click the Retouch button , adjust the “Brush Size” slider to 
match the size of the blemish, click on the blemish. If the blemish goes away, click again without 
moving the mouse, otherwise move the mouse to a nearby area that makes the blemish disappear, 
then click. Repeat for each blemish. Click Apply button to accept, or Cancel to start over..

7. Click the  tab at the top of the left-hand panel to experiment with Fill Light (brightens the dark 
portions of a photo), Highlights (brightens the light portions of a photo), Shadows (darkens the 
dark portions of a photo), or Color Temperature - makes the color warmer (more red) or colder 
(more blue). Click the  tab for special effects, such as “Sharpen”or “B&W”.

8. To undo any of these operations, click on the Undo button on the left. Each time you press Undo, 
it removes one operation, all the way back to the original photo.

9. To go to the next photo, click the right arrow button      at the top of the screen. To return to the 
thumbnails, press the Esc key on the keyboard OR click the Back to Library button.

 Note: There is no need to save after editing each picture; all edits are automatically saved within 
Picasa. However, if you want to use a folder of edited photos with other software, click the      
button above the thumbnails. (To save a copy of the edited photo as a separate photo, pull down File 
and click Save a Copy. Then you will have both the original and the edited version).

Making Picasa albums   
In Picasa, albums are lists of particular photos selected from different folders and arranged in a specific 
order. An album contains only a list of photos, not duplicates of photos. The photos in an album are not 
actually duplicated or moved from where they were, so they don't take up extra disk space. Create as 
many albums as you like, and use the same photo over and over again in different albums, all without 
wasting disk space. You can do anything to an album that you can do to a folder of photos: print, email, 
order prints, export them to a USB drive, make a Gift CD, slide show, or shared Web album. 
To create an album, click on the blue book button  in the upper left, type a name for the album, and 
press OK. To add photos to that or any other album, select the photos*, then click  at the bottom 
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left and select the desired album from the pop-up list. Note: putting a photo in an album does not 
remove it from its folder or make a duplicate of that photo. Picasa shows the albums you have created 
at the very top of the folder list, so they are easy to find. To delete an album, right-click on it and select 
Delete Album. Deleting an album does not actually delete the photos; they remain where they always 
were. To rearrange the order of the pictures, just drag and drop a thumbnail into the desired position. 
* To select a photo, click once on its thumbnail in the Library. A blue border indicates that the picture 
is now selected. To select multiple photos from one folder, hold down the ctrl key and click once on 
each thumbnail. To select multiple photos from more than one folder, click the green “stick pin” button 

 (bottom left) after selecting each picture. Click the red circle to clear the tray.
Printing pictures on your own ink-jet printer 

1. For best results, load your printer with glossy photo paper rather than plain paper. 
2. Click on a thumbnail in the library, and then click the Print button at the bottom of the window. 

OR if the picture is already open, just click the Print button. To print several different pictures, 
click once on the thumbnail of each picture that you want to print and click the Hold button  
(looks like a green stick pin) below the thumbnails. Repeat for each picture. Then click Print.

3. Select the desired Print Layout on the top left. (If you want multiple prints, click on the + and - 
buttons near “Copies per picture”.) Optionally, click Review to check print quality, then OK. 

4. Click Shrink to fit or Crop to fit and use whichever looks best. 
5. If you want to print the caption or create a custom border, click Border and Text Options.
6. Click the Printer button on the left panel and select the printer that you wish to use.
7. Click the Printer     Setup   button and select the paper type and size that you are using. 
8. Click the Print button at the bottom right. 

It is often cheaper and faster to order prints from an online photo finisher than to print them yourself. See 
http://terpconnect.umd.edu/~toh/adulted/Intro.pdf, Page 12, for a detailed procedure for Walmart.

Emailing pictures   To email pictures directly from Picasa, open Picasa first, then:
1. Click on a thumbnail in the library, and then click the Email button at the bottom of the window. 

(To email several pictures at once, click once on the first thumbnail, click the green pin button 
and repeat for each picture, then click the Email button). The “Select Email” window pops up.

2. Click which email service to use. The one at the top is the default email for that computer. If that's 
the program you use for email, click it and finish composing the email as usual in the resulting 
window. If not, choose Google Mail, type in your Gmail user name and password*, and click Sign 
in. (If you're not on your home computer, do NOT click “Remember me on this computer”).

3. Type in the e-mail address of the recipient and click Send. Even better, send it to your email 
address first, then log in to your email as usual and forward it to people in your address book.

* If you don't have a Gmail account yet, follow these instructions at to get a free account. So you won't 
forget, write your Gmail username _____________________ and password ______________ here! 
Your Gmail account won't effect you regular email, no one needs to know your Gmail address, and you 
need it only for sharing pictures by sending them to your regular email address to forward.
Note: To change the size of the pictures sent, click Tools > Options > E-Mail and choose the size.
Saving pictures received by Email
Pictures received by email must be downloaded and saved into the Pictures folder in order to be viewed 
in Picasa. The exact details vary with the email service, but most email services display thumbnails of 
attached pictures with links or buttons or checkboxes to download the photos. For example, using 
Yahoo, Hotmail, or Gmail with Internet Explorer, select a thumbnail, then click Download > Save > 
Pictures > Save. If your email service has no download or save button, right-click the picture in the 
email and click “Save Picture As...” and save as above. If your email displays only icons rather than 
pictures, right-click and select Save.... (If you don't want all your saved pictures mixed up in the 
Pictures folder, click “New folder” after clicking Pictures, type a name for the new folder, and press 
the Enter key. The next time you save a picture, Windows will remember the last save location used).
Putting pictures and slide shows on a CD (“Gift CD”) to send by postal mail.
 If you have a CD/RW drive, Picasa can burn a slide show CD to send via postal mail: 

1. In the left-hand panel of the Library, click once on a folder (or album) that you want to include on 

https://picasaweb.google.com/Tom.Mary.OHaver/GettingAGoogleAccount?authuser=0&authkey=Gv1sRgCNO1lNT4oNjlIw&feat=directlink
http://www.wam.umd.edu/~toh/adulted/Intro.pdf
https://picasaweb.google.com/Tom.Mary.OHaver/PrinterSetupBoxes?authuser=0&feat=directlink
https://picasaweb.google.com/Tom.Mary.OHaver/PrinterSetupBoxes?authuser=0&feat=directlink
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the disk. Then pull down the Create menu and click Create a Gift CD...
2. If you want to include more that just that one folder or album, click the Add more... button at the 

bottom left, then in the folder list, click the check boxes to the left of each folder or album that you  
want to include. (Each folder or album makes a separate slide show on the disk), up to 5 or 6.

3. Click Burn Disc. Insert a blank CD-R (not a CD-R/W) and click the Continue button. If a pop-up 
menu appears, close it.

4. When burning is complete, Eject the disk. Thereafter, when this disk is inserted into most PCs, a 
slide show menu will usually display automatically after a several-second delay. (If a pop-up 
appears, click “Run PicasaCD.exe”. If nothing happens, click Start > Computer, right-click on the 
CD icon and select Explore, then double-click “PicasaCD.exe”. Click on a picture to play that slide 
show. (This disk will also show the pictures on TV in most DVD players, without captions).

Sharing your photo albums and slide shows over the Web  
Do this if you are having trouble emailing pictures, or you want to send more pictures and videos than 
email can handle. Sending photos this way makes it easier to see the captions and to play slide shows.

1. Right-click on the folder or album name and click “Upload to Picasa Web Albums...”. 
2. Enter your Gmail password and click the Sign In button. (The first time you do this, and only the 

first time, you will sign up for Picasa Web Albums; it's free; just follow the screen instructions).
3. Click the Album visibility menu and select Anyone with the link. That means that only people 

you invite in the next step will be able to see those pictures. No one else can see them.
4. In the “To:” box in the center, type in an email address, add a message if desired, and click the 

Send button. Hint: I recommend that you send the invitation to your regular email address first, 
then go to your email in the usual way and forward it to people in your address book. 

After you click Send, the “Upload Manager” will upload the pictures to a private area on the Web 
and display the upload progress, which may take several minutes. When it finishes, close the Upload 
Manager window or click on the View Online button to see what it will look like to your recipients. 
Important: When you are working in a public place, click Sign Out in the upper right when you are 
done, so other people using that computer won't interfere. (At home, it's OK to remain signed in).
Recipients will receive an email from you with the subject line “Invitation to view....”. They need 
only open that email and click on “View Album” or “View Slideshow”, and their web browser will 
open and show them the pictures (complete with any captions you may have added). Only the people 
you invite can see those pictures. They do not have to give their name or their email address, etc, and 
they do not need to have Picasa or a Google account to see the photos. They can download the 
pictures to their hard disk if they wish, by clicking on the “Download” button above the thumbnails.
Note: To add a photo to an existing Web Album, right-click it, click “Upload to Picasa Web 
Albums.”, select the desired Web album under the menu at the top, and click the Upload button. To 
view those pictures on the web, click Web Albums in the upper right corner of Picasa. 

Backing up photos and albums to CDs, DVDs, or external hard drives  
This is useful for restoring photos that have been purposefully deleted (to recover disk space), that 
have been accidentally deleted, or that have been lost because of a computer crash. It can also be 
useful for transferring photos and albums from one computer to another. 
1. Click Tools > Backup pictures.
2. Click the New Set button and type a name for that backup (e.g. “Photos as of April 2012”)
3. If you are backing up to CD or DVD, click CD/DVD backup and skip to step 5. 
4. If you are backing up to external hard disk or USB drive, plug in that device to a USB port, click 

Disk-to-disk, click the Choose button (top right), double-click Computer, and from the list below 
Computer click on the device that you want to export to. Click OK.

5. Click Create.
6. Click Select All to back up all pictures or click just the check-boxes on the folders and albums you 

want to back up. (Don't forget to back up the “blue book” albums that you have created). 
7. Click the Burn or Backup button in the lower right.
8. The screen will display the progress of the backup. (If you're making a CD or DVD backup, you 
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will be prompted to insert one or more blank disks. Label them as prompted and store the disks).
To restore the photos to the hard drive, insert the (first) disk into the computer (or open the external 
hard disk and double-click PicasaRestore.exe), wait until the pop-up box appears, click Next, and 
then click Restore. Wait until the restore is complete. For further help, press F1, then click “Backing 
up your Pictures”.
To export a single folder or album to a USB drive, select that album or folder, click the Export 
button  at the bottom of the library screen, click Browse and select the USB drive, check “Add 
numbers to file names to preserve order”, choose the desired image size, then click Export.

Face Detection and Recognition 
Picasa has the ability to recognize human faces in your photos and to present them to you for 
naming. I recommend turning off this function at first if you are new to Picasa. This function takes 
a lot of computer power, so if you have a lot of pictures and your computer is an older model, it 
may run too slowly. Turn it off by going to Tools > Options > Name tags and un-checking the two 
check boxes. Turn it back on later and it will continue where it left off. For more information on 
how to use the face detection capability, Google the phrase “Picasa name tags”.

Place tags 
    To view and set the location where photos are taken, click the  tab in the lower right. Or select 

photos, then type in a address or place name where that group of pictures was taken (e.g. Naples, 
FL) into the “Search for an address” box at the bottom of the Places panel. Or click the green “map 
pin” in the upper left of the panel and then click on a place on the map. Newer cameras with GPS 
(e.g. iPhone, Panasonic TZ10) automatically add exact “place tags” to each photo taken. 

Taking Videos
    Most digital cameras can take video clips as well as still photos. Picasa can handle the videos, 

within certain limits. If you want to include videos in your Picasa library, click Tools > Options > 
File Types and click Movies and Quicktime Movies. You'll need to update Windows Media Player 
(http://windows.microsoft.com/en-US/windows/products/windows-media-player ) and Quicktime 
(http://www.apple.com/quicktime/download) to the latest versions. With most (but not all) cameras, 
Picasa imports the videos along with the photos. If Picasa does not import your videos, try the 
software that came with your camera or computer instead. 

    You can view, caption, email, export, backup, and upload videos to Web Albums or YouTube, but 
you can't edit, print, download videos from Web Albums, or view them on Gift CD slide shows. 
(Note: To email movies, click Tools > Options > Email and click “Send movies as: Full Movie”). 

    You can capture still frames from a video by clicking the “Take Snapshot” button during play. 
The frames will be stored in “Captured Videos”, on the left of the library screen, above Folders. 

Further help. 
Click the Help menu to access the help texts. Visual learner? Go to youtube.com and type “picasa” 

or “easy picasa” or whatever into the search field to find videos that show you step-by-step.
Links to other related topics on http://tinyurl.com/9znkph     

 Practice Editing Tasks for Picasa *    How to Order Prints from within Picasa  

 Importing Images into Documents  Choosing and Using a Scanner *

 Loading Pictures onto a Photo Frame  Webcams and Skype

 Which Program Should I Use?  Adding External Storage to Your Computer

 Collages, Posters, and Movies  Adding music to slide shows from CDs

 Finding and removing duplicate photos  Copying and Moving files and folders

 Overview of Digital Photography  Screen saver and desktop pictures

 Troubleshooting  The Different Kinds of Disks

 Stitching several photos together into panoramas *  Programs for making Video   Slide   Shows  

* Photo examples to download are available on https://picasaweb.google.com/Tom.Mary.OHaver/
© Tom O'Haver (toh@umd.edu), January 2013
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