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APPENDIX C 

Using PSpice with Analog Circuits 

There are a large number of codes that can be used to simulate circuit performance. We will 

use the circuit simulation code PSpice. Students can get a free version of PSpice, at least for 

some period of time, here: https://www.orcad.com/orcad-academic-program. You can also use 

PSpice via the University of Maryland’s Virtual Computer Lab (VCL): https://eit.umd.edu/vcl. 

After you log in, click on: “Cadence 17_2 Design Entry CIS. You must have already downloaded 

the “Citrix Workspace App,” otherwise, go here or similar for your operating system): 

 https://www.citrix.com/downloads/workspace-app/windows/workspace-app-for-windows-latest.html. 

In this tutorial, we will demonstrate how to simulate three dif-

ferent circuits. It is assumed, as you go through the tutorial, that you 

are seated in front of a PC that has PSpice, that runs some current 

version of Microsoft Windows™, and that you are basically familiar 

with that operating system.  

The first program to simulate 

is the DC circuit shown in Fig. 

C.1. From Windows™, open OR-

CAD Capture CIS (or CIS Lite if 

it is the free demo version). On the 

getting started page you can click 

on “New Project”, or from the 

dropdown menu system click on 

File → New → Project. The drop-

down menu that appears is shown 

in Fig. C.2. Type “test” for the 

project name and click on “Ana-

log or Mixed A/D”. Type in 

“C:\temp” for the location and 

click the “OK” button. Next, the 

1 5 V 2 3 

Fig. C.1. A DC circuit.

Fig. C.2. The New Project Menu 

https://www.orcad.com/orcad-academic-program
https://eit.umd.edu/vcl
https://www.citrix.com/downloads/workspace-app/windows/workspace-app-for-windows-latest.html
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“Create PSpice Project” 

menu will pop up (see Fig. 

C.3). click on create a blank 

project and click “OK”. 

At this point the OR-

CAD Capture CIS drawing environment will open up on 

the computer screen and we are ready to begin drawing 

a circuit. Rather than give a comprehensive description 

of all of the menu items and options accessible on this 

page, we will take a more directed approach that will 

allow us to perform the simulation related to the circuit 

in Fig. C.1.  

We need to place four parts on the schematic draw-

ing: One DC voltage source and three resistors. We need 

to connect the parts together with wires. PSpice requires 

that all circuits have grounds defined (zero volts), so we 

will need to place a ground as well. From the Place → 

Part drop down menu we will place the four compo-

nents. After clicking on Place → Part sequence, the 

menu in Fig. C.4. will appear, normally on the right side 

of the screen. If the only Library shown is “Design 

Cache”, you will have to add more libraries. Above the 

box of libraries are two icons. The right icon is a “delete 

library” icon. To the left is the “add library” icon. Click 

on the “add library” icon and add all of the available li-

braries. (Note: You can get other libraries on line from electronic component manufacturers to 

improve the accuracy of your circuit simulations for specific components.) When you have some 

libraries available, type “Vdc” in the part box and hit enter. Now the Place Part dialog box will 

appear as in Fig. C.5. 

Fig. C.4. The 

Place Part Menu 

Fig. C.3. The Create PSpice Project Menu 
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Move the mouse to the drawing area and 

right click to place a battery of zero volts, with 

the name “V1” in the schematic. Right-click the 

mouse and click on “End Mode” to stop placing 

batteries (see Fig. C.6.) Move the mouse over the 

“0V” and double-click the left mouse button. The 

“Display Properties Menu will appear (Fig. C.7). 

Change the voltage to 5Vdc and click “OK.” You 

have just added the 5V battery. 

Move the mouse over to the part box and re-

place Vdc with “R” for resistor. Hit enter. Move 

the mouse over to the drawing area and left click 

three times, moving the mouse to the right before 

each new click. Try to place the resistors exactly 

in the same line – that will make things a little 

easier later if you can do that. Right click and 

then select End Mode to stop placing resistors. 

The three resistors are incorrectly rotated by 90 

degrees and have a value of 1k each. 

The third resistor R3 should be highlighted (it is pink while the other two resistors are blue). 

Click on the drop down menu Edit → Rotate. The third resistor should now be parallel to the bat-

tery. Double-click on the resistance value and change it to “2” in the Display Properties box that 

appears. No units are necessary. If you had needed to include an SI prefix (p. n, u, m, k, MEG), 

there would be no space allowed between the component value and the prefix. Move the mouse 

over R1 and left-click. Repeat the procedures above to rotate the resistor and change the re-

sistance to 1. Repeat the procedure for the middle resistor, giving it a value of 3. At this point 

you have placed all four components. 

Next, the components must be connected by wires. Use the drop-down menu: Place → Wire. 

Cross-hairs will appear when you move the cursor over the schematic. There are many common 

Fig. C.5. The Place 

Part Menu 
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errors that prevent PSpice from working correctly, and placing the wires incorrectly is a particu-

larly frustrating error, so take care with this process.  

 

Place the cross-hair directly over 

the small square box at the top of the 

5V battery (this square represents one 

of the two terminals of the battery (the 

positive terminal in this case) and left 

click the mouse. Move the cursor over 

to the right-most resistor. If you have 

lined up the resistors correctly, there 

should appear three red circles. These 

circles indicate that the wire will con-

nect to the terminals of these compo-

nents once you left-click the mouse. This is exactly what we want to do, so left-click again, and a 

wire should appear connecting one terminal of each of the four components together. If some 

reason the resistors are not aligned, you will have to repeat this process. Once you place one 

Fig. C.7. Display Properties Menu 

Fig C.6. The Schematic drawing environment and the menu used to “End Mode”. 
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wire, you remain in the place wire mode, so just repeat the two-click sequence to place the next 

wire. When you finish making the top node, make the bottom node by placing a wire between 

the lower terminals of all four components. Right click and select “End Mode” to stop placing 

wires. 

The final component 

that we must add is the 

ground connection. Use 

the drop down sequence 

Place → Ground to pro-

duce the menu shown in 

Fig. C.8. Type in “0” to 

get the ground we need 

in press “OK”. Place this 

ground anywhere along 

the bottom node with a 

left-click, and end mode 

with a right-click. Make 

cure the red circle appears to ensure that you are making a good connection to the node. We are 

now done drawing the circuit; you may want to save your work with File → Save or by pressing 

the Save Icon (the picture of the obsolete floppy disk).  

The next step is to tell PSpice what type 

of simulation we want to do, so we need to 

use the drop-down sequence PSpice → New 

Simulation Profile. In the “New Simulation” 

dialog box that appears. Type in any name 

that you wish and press the “Create” button 

(see Fig. C.9.). 

To make the analysis part a little easier, we can indicate where we would like to measure 

circuit variables. On the lowest toolbar on the upper left part of the screen, there is a picture of 

different oscilloscope probes. From left-to-right, they are for measuring: voltages (with respect to 

Fig. C.8. The ground dialog box. 

Fig. C.9. The New Simulation Menu 



 6 

ground), voltage differences, currents, and dissipated powers. Click on the current probe icon. 

Move the cursor so that the icon tip is touching the upper terminal of the voltage source and left-

click. Place current probe at the upper terminals of all three resistors too. Then right-click to end 

mode. The circuit should look like the one in Fig. C.10. We have zoomed in on the circuit and 

moved the location of the resistor names and component values to make the circuit easier to see, 

so the drawing will not look just like yours unless you do the same. 

 

Normally, one would have to edit the simulation profile, but since this is a simple DC analy-

sis, we can just use the drop-down sequence PSpice → Run to initiate the simulation. A warning 

box will appear saying that you will not be able to “undo” anything after running the simulation. 

Push the “yes” button to proceed. The simulation will complete if there are no errors, and the 

probe program will launch. The current probes on the circuit schematic will change colors to in-

dicate the color each measurement has in the probe window. The node voltages that correspond 

to the DC “bias point” will appear on the schematic – for this circuit the two nodes are at ground 

(0 volts) and 5 volts. Before we look at the simulation output, note that creating, editing, and 

viewing the simulation profiles, as well as initiating the PSpice simulation can also be done via 

the four icon buttons that are to the left of the four probe icons on the toolbar.  

Fig. C.10. The PSpice circuit schematic that corresponds to the 

circuit in Fig. C.1. 
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The Probe output is shown in Fig. C.11. The results are plotted for  s, but it is a DC cir-

cuit, so nothing varies with time. Note that the sum of all four currents is zero. This is a conse-

quence of KVL, the way that we placed the components, and PSpice, which uses the passive sign 

convention for all components, including sources. Thus, the battery is supplying power to the 

circuit, since the current going into the positive terminal is negative.  

Note that after the simulation is complete, in the schematics window, the three icons to the 

right of the probes are available and can be pressed to show (or hide) all node voltages, all com-

ponent currents, and all component powers. Note the battery power displayed is negative, anoth-

er consequence of using the passive sign convention for the battery. 

The next circuit that we will model with PSpice is 

shown in Fig. C.12. While we could add this circuit to 

the current schematic, we will exit PSpice and enter 

again to start from scratch. Fewer steps will be present-

ed in this part of the tutorial, as we will highlight only 

the parts that are new to this simulation.  

There are many types of voltage sources. We are going to perform a transient analysis with 

this circuit, so we will use one called VSIN, which is located in the SOURCE library. VSIN has 

Fig. C.11. The probe output screen for the circuit of 

Fig. C.1. 



2 k 22 F5 sin(60t) V

Fig. C. 12 The second circuit to simulate.
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four parameters that can be adjusted and are listed to the left of the source symbol. The formula 

for the voltage source is: 

V(t) = VOFF + VAMPL*SIN(2*FREQ*t);  

so VOFF is an offset dc voltage, VAMPL is the peak sine wave voltage, and FREQ is the sine 

wave frequency. The fourth parameter, AC, is for a frequency analysis and we do not need to 

give a value for our analysis. Put VOFF=0V, VAMPL=5V, and FREQ=60/2 ≈ 9.55. 

Place the resistors and the capacitor as indicated in the figure. The name for a capacitor is 

just “C” and it is in ANALOG library. Add the zero ground and connect all components with 

wires. The circuit should appear as in Fig. C. 13. The figure indicates that we will look for the 

voltages of the source and across the capacitor. 

 

Create a new simulation profile and edit it. Change the “Run to time” to 250 ms (as in Fig. 

C.14. and click on the “Skip the initial transient bias point calculation” button. This will force all 

voltages in the circuit to start from zero (except for the voltage source). Press o.k. Add the two 

voltage probes as indicated in Fig. C. 13 and run the simulation. The probe output should look as 

in Fig. C. 15. 

Fig. C. 13. The PSpice schematic drawing of the second example circuit. 
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The probe program itself can be used to glean much information from the circuit, beyond 

what the initial circuit probes ask it to do. As an example, let’s plot the current through the ca-

Fig. C. 14. The simulation settings for the second example. 

Fig. C. 15. The Probe output for the second example. 
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pacitor. In probe, use the drop-down menu Plot → Add plot to window. A new plot will appear 

above the original plot, and there will be a SEL>> to the left of the new plot. This indicates that 

we have selected this new plot for now, and are ready to make changes to it. Now use the drop-

down menu Trace → Add 

trace. The add traces dialog 

box appears as in Fig. C. 16. 

Click on “Voltages” 

and “Power” to remove the 

check marks and reduce the 

number of variable in the 

list. Click on I(C1) to plot 

the current through the ca-

pacitor. Finally, click on 

Trace → Cursor → Display. 

Left and right-click at vari-

ous points on the plot and see how the cursor variables change in the box in the lower right cor-

ner of the probe window. The Probe output should now appear as in Fig. C. 17. 

 

C. 16. The Add Traces dialog box 

C. 17. The Probe Output for the second circuit. 
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The circuit for the final example is shown in Fig. C. 18. 

Start from scratch in PSpice to build the circuit. The name 

for an inductor is “L”. Use the VAC source, and leave the 

default values (1V maximum for an “AC” steady-state analy-

sis.) The goal of this example will be to see how the voltage 

magnitude across each passive component changes with in-

put source frequency. 

 

The circuit as drawn in the schematic editor is shown in Fig. C. 19. Since one side of the ca-

pacitor is connected to ground, we can find the voltage from a single probe. To find the inductor 

voltage, we need to use differential voltage probes. When the circuit is drawn, create and edit a 

simulation profile. You need to select the analysis type; we will do an AC Sweep (see Fig. C. 

20). We need to choose the frequency range – we will go from 10 Hz to 10,000 Hz. We also 

need to choose the number of frequencies to be simulated. Since this is such a large frequency 

range, we will use a logarithmic placement of frequencies, and plot 20 data points / decade. 

The probe output is shown in Fig. C. 21. Note that the voltage across the resistor was added 

after Probe was initiated. 

AC

50 

10F

10mH

Fig. C. 18. The final example circuit.

Fig. C. 19. The schematic drawing of the final example circuit. 
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Fig. C.20 The simulation setting for the AC analysis. 

Fig. C.21. The probe output for the final example. 


